charset geht nicht bei umlauten

  • Hallo,
    eigentlich sollte die neue schreibweise <meta charset="UTF-8" > auch bei umlauten gehen.
    Umlaute zeigt er aber bei mir nicht an, bei beiden browsern firefox und chrome.
    bei der alten schreibweise, habe die als bemerkung noch darunter, zeigt der browser mir die umlaute an.
    man sollte aber die neue schreibweise benutzen,
    ich habe noch xp, kann das daran liegen?
    habe den html-code unten beigefügt.
    mfg gerhard


  • ja cotton, du hast recht, ich habe es mal mit meinem normalen editor abgespeichert und dabei codierung utf-8 angegeben, da ging es.
    aber mein komodo ist sehr gut, aber diese codierung kann ich dort nicht angeben.


    jetzt überlege ich, ob ich die alte schreibweise einfach lasse, den komodo will ich eigentlich behalten.
    oder kennt jemand den komodo edit 8, vielleicht gibt es da eine andere möglichkeit?
    da muss ich selber nochmals probieren.


    mfg
    gerhard

  • sublime text hebe ich mir mal für später auf, das wird doch irgendwie hinzubekommen sein,
    das komodo edit 8 das so speichert, dass es mit utf-8 funktioniert, da hätten ja andere das gleiche problem.
    aber eine problem durch den editor hätte ich hier nie gedacht, die datei wird ja auch als .html gespeichert.
    mfg
    gerhard
    o.k., habe es gefunden.
    unter file setting kann man die voreinstellung dafür machen.
    aber nochmals danke für die hilfe.
    mfg
    gerhard
    Hallo,
    jetzt ist nochmals eine frage aufgetaucht.
    es geht jetzt ohne auch die css-datei umzustellen, nur die . html.


    aber gibt es da auch eine empfehlung?
    ich könnte die css-datei auch mit codierung utf-8 abspeichern.
    was ist da zu empfehlen, gibt es da ggf. noch nebenwirkungen wenn man es nicht macht?


    viele grüße
    gerhard