Favicon wird nicht genommen

  • Hallo,


    ich habe ein Problem...


    Ich binde in meine HTML-Datei ein Favicon ein, welches in Chrome dargestellt wird, aber nicht z.B. im IE...


    wer kann mir helfen?


    Code ist wie folgt:


    HTML
    1. <!Doctype HTML>
    2. <html>
    3. <head>
    4. <meta charset="utf-8">
    5. <title>Flo's Fotographies</title>
    6. <link rel="shortcut icon" href="favicon.ico" type="image/x-icon"/>
    7. <link rel="stylesheet" type="text/css" href="style.css" />
    8. </head>
    9. ...
    10. </html>
  • Welche Version des Internet Explorers?


    Wie hast du das Icon erstell? Chrome z. B. kommt mit simpel umbenannten Bitmaps klar, IE nicht.


    Der Internet Explorer läd Favicons nur beim ersten Besuch der Seite. Leere deinen Cache und versuche es erneut.


    Ansonsten so versuchen:


    HTML
    1. <link rel="icon" href="favicon.ico" type="image/x-icon">
    2. <link rel="shortcut icon" href="favicon.ico" type="image/x-icon">
  • 1. ist die Datei nicht online, sondern ich öffne die HTML-Datei local. Ich weiß nicht ob der cache da was bringt :D


    2. habe ich das Icon mit einem Online-Generator anhand einer PNG-Datei erstellt.


    3. habe ich es mit diesem Code auch schon versucht. Überall (Firefox, Opera, Chrome) wird das favicon dargestellt blos nicht im IE und im ME


    4. Benutze ich die neueste Version des IEs, also IE11



    EDIT:



    Ich habe die Datei mal auf den Webserver geladen und dort wird das Favicon angezeigt.


    Kann das nun am localhost liegen?

  • Ja, z.B. am dateiname, abgesehen davon gibt es keine neue version von IE da die neuste version schon veraltet ist und es hoofentlich nie wieder einen IE geben wird. Der IE wurde durch Edge ersetzt, Edge 14 ist zurzeit die Neuest Version des Windows eigenen Browsers..


    Hast du den realfavicon generator probiert..?

  • Wobei ich den Edge auch nicht gerade besser finde als IE :D



    Wie gesagt sobald die html-Datei auf dem Webserver war und ich das im IE geöffnet habe, hat er das favicon angezeigt...


    Deshalb hatte ich den nicht ausprobiert :D