$_POST-Problem

  • Hey! Ich habe folgende Situation:
    Ich habe eine Webseite mittels PHP gecodet. Dort kann man einen Usernamen eingeben und bekommt daraufhin Informationen über diesen User angezeigt.

    Das mache ich mit einem $_POST-Formular. Jedoch sollen auf die einzelnen Userseiten auch noch ein Formular, mit welchem man Daten in SQL ändern kann.


    Problem ist hierbei: Wenn ich das Formular auf der jeweiligen Unterseite absende, wird die komplette Seite neu geladen. Die Daten werden nicht übermittelt und man landet wieder auf der "User suchen"-Seite. Wie kann ich dieses Problem beheben? Wo ist mein Denkfehler? :/

  • Wie so oft gilt auch hier:


    Richtig debuggen

    1. Man bemerkt, dass ein Skript nicht das tut, was es soll.
    2. Man schreibt an den Anfang des Scriptes die Zeile: error_reporting(-1);
    3. Man verwendet ini_set('display_errors', true); damit die Fehler auch angezeigt werden.
    4. Man versucht, die Stelle die daran Schuld sein kann, schonmal einzugrenzen. Falls dies nicht geht, wird zunächst das komplette Skript als fehlerhaft angesehen.
    5. An markanten Stellen im Skript lässt man sich wichtige Variableninhalte ausgeben und ggf. auch in bedingten Anweisungen eine kurze Ausgabe machen, um zu überprüfen, welche Bedingung ausgeführt wurde. Wichtig bei MySQL Fehlern (...not a valid MySQL result resource...): mysqli_error() verwenden oder Abfrage ausgeben und zb mit phpmyadmin testen.
    6. Schritt 5 wird so lange wiederholt, bis Unstimmigkeiten im Skript auffallen
    7. Damit hat man das Problem (Unstimmigkeit) gefunden und kann versuchen diese zu beheben. Hierzu dienen dann die PHP-Dokumentation und andere Quellen als Ratgeber.
    8. Lässt sich das konkrete Problem trotzdem nicht beheben, kann man in Foren um Rat fragen.
    9. Das Programm läuft und man kann die Debug-Ausgaben wieder entfernen.
  • Ich bin jetzt schon seit ich diesen Post geschrieben hatte bei Schritt 8.


    Folgendes Situation:
    > Wenn ich direkt in die besagte admincheck.php reingehe, funktioniert alles. Das Formular wird gepostet und die Webhook korrekt versendet.

    Wenn ich das jetzt jedoch include, geht es nicht mehr.


    Ich muss die action ja dann ändern:

    Code
    1. # in admincheck.php
    2. <form action="admincheck.php">
    3. # included
    4. <form action="checkuser.php">


    Wenn es included ist, geht es nicht mehr. Da lässt sich blöderweise nichts debuggen. Die Frage ist, wie man das umgehen kann..

  • Hey,


    dieser Codeteil bei admincheck.php:

    macht keinen Sinn. Darüberhinaus wird dieser Code auch nicht ausgeführt. Du leitest nach dem Klicken des Submitbuttons auf die checkuser.php weiter. Dort musst du überprüfen ob $_POST["smtrng"] vorhanden ist.


    So wie es aussieht hast du nicht richtig gedebugt. Bitte wiederholen!


    Grüße,

    Stef