Warum bekomme ich manche Grafiken nicht in meine Webseite geladen?

  • Hallo! ( ich bin ein totaler Anfänger)


    Ich benutze den HTML-Editor "Bluefish" auf Ubuntu. Damit bekomme ich verschiedene Grafiken (PNG oder JPG, von 10 - 420kb - Zeichnungen, Fotos) in meine Webseite geladen! Nur manche Grafiken wollen einfach nicht, obwohl sie die gleiche Größe, usw. haben. Wenn ein Foto sehr groß ist, macht sich die Webseite einfach Platz, und die Spalte wird dann automatisch breiter.


    Das funktioniert:

    <p><img src="Borduere 14 (Kopie).png" alt="Borduere 14 (Kopie)" /></p>

    <p><img src="Auswahl_004.png" alt="Auswahl_004" /></p>


    Das nicht:

    <p><img src="Borduere 14 gespiegelt.png" alt="Borduere 14 gespiegelt" /></p>


    Da habe ich mehre Grafiken, die nicht gehen! - Kapier ich nicht!!! - Aber alle sind sie sich sehr ähnlich! - Die nicht Ähnliche (das Auto) funktioniert! - Merkwürden!


    Die "gespiegelte" geht nicht, wohingegen die "Kopie" funktioniert! - Das Auto (nicht meins - leider - lach) wird auch geladen! - Die Namen habe ich schon angeglichen (nur Name, Leerstelle, Ziffer - diese Kombination des Namens funktioniert, selbst wenn ein Name mit Klammer angegeben wird), aber daran liegt es nicht!


    LG

  • Thanks 4 answers!


    @ AndreasB: So ähnlich! Ich habe dir einen Screen hochgeladen. - Die Grafiken sind alle im selben Ordner, die Dateinamen sind die, die ich auch hier im Forum rein gestellt habe. Da sind keine Sonderzeichen oder Umlaute wie aüö dabei. - Deswegen wundert mich das ja auch!


    <p><img src="Borduere 14 gespiegelt.png" alt="Borduere 14 gespiegelt" /></p>


    @ Basti1012: Nein

  • Läd er die Bider gar nicht , oder sehen die nur so aus wie du es gezeigt hast?

    Ich meine das eine gespiegelte was dann andere Farben hat?

    Dann hätte ich gesagt schau ma in der Css nach irgendwelche Filtern.


    Wenn nur der alt Text angezeigt wird ist es ja eigentlich ein Zeichen das dies Bild erst gar nicht geladen werden kann,

    Dann würden Filter und Css da auch nicht stören.


    Du solltest das unbeding mal online stellen weil so kommen wir nicht weiter.

    Die Bilder sind alle in ein Ordner sagst du ja.

    Kann es sein das die Bilder mit verschiedene ( iclude datein ) oder so eingebunden werden und die in anderen Verzeichniss liegen.

    Verschiedene Css Datein die in verschiedene Ordner liegen haben dann auch andere Pfade zum Bild ( nur bei background Images )

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von basti1012 ()

  • Egal was behauptet wird: Viel Frust und Ärger werden vermieden, wenn für Ordner- und Dateinamen nur die Kleinbuchstaben des englischen Alphabetes, Zahlen und der Unterstrich verwendet werden. Wobei Zahlen nicht als erstes Zeichen stehen sollten. Kein Leerzeichen, keine Umlaute, keine Sonderzeichen, keine anderen Striche als der Unterstrich.


    Ansonsten kann es zum Beispiel auch passieren, dass die Seite bei einem selbst komplett und korrekt angezeigt wird, bei Besuchern mit anderen Providern, anderer Hard- und Software, anderen Betriebssystemen aber nicht.

  • Was jetzt passiert ist, ist wieder mal mehr als merkwürdig: (dieselben Grafiken, die vorher nicht laden wollten, werden jetzt problemlos geladen)

    Ich wollte die ganze Seite mal online stellen (Lima-City), und habe dafür den ganzen Quelltext der einen Seite (im Editor Bluefish) kopiert, und ihn einfach in einem neuen TAB im Editor eingefügt! - Ohne Veränderungen! - Einzig und allein der Titel der Seite, der dann im selben Ordner (wo auch die Originalseite drin ist) ist, hat einen anderen Namen bekommen. Habe sie dann Spaßens halber mit dem Firefox anzeigen lassen (wie ich das immer mache), und da wurde die Grafik auf einmal auf der Webseite angezeigt!!! - Merkwürden!!!


    Auf beiden Seiten ist original derselbe Quelltext!!!

  • Könnte ein Problem mit dem Cache sein, gerade wenn Du schreibst, dass die Bilder mit dem selben HTML geladen werden, wenn Du eine neue Seite angelegt hast. Versuche, die Seite mit Strg+F5 neu zu laden. Wenn ich mich richtig erinnere wird auch im Netzwerk-Tab der Entwicklerwerkzeuge angezeigt, wenn etwas aus dem Cache geladen wird.

  • Außerdem git es bei allen Browsern in den Entwicklerwerkzeugen (meist im Netzwerk Tab) eine Checkbox, die den Browsercache, so lange wie die Entwicklerwerkzeuge offen sind, deaktiviert.

    Diese Option sollte bei der Entwicklung immer angeschaltet sein (außer man möchte die Performance überprüfen, denn die leidet natürlich unter einem deaktivierten Cache).

  • Ein großes Dankeschön mal wieder an alle, die mich hier so liebevoll unterstützen!!!


    Ich habe es erst einmal geschafft, die Seite online zu stellen, damit ihr eine bessere Vorstellung habt! - Einige "Schreibereien" im Quelltext sind irgendwie unsinnig, unnötig (habe ich beim Verändern der Seite bemerkt; ich nehme was raus - eine Farbe z. B. - aber es verändert sich nichts, lach), aber sie funktioniert erst einmal "im großen Ganzen", wie ich es mir vorstelle. - Ist ja auch nur wieder ein Neuanfang, wo ich vor ca. 9 Jahren aufgehört habe.


    https://xxxtommyxxx.lima-city.de/

    Dateien

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von Thommy402 ()

  • Bei Borduere 14 rechts hast Du die Erweiterung vergessen, so ist es richtig:

    Code
    1. <img src="http://www.xxxtommyxxx.lima-city.de/Bilder/Borduere 14 rechts.png" alt="Borduere 2014 rechts.png">
  • Trotzdem hast du recht gehabt! - Jetzt krich ich sie erst mal geladen! - Danke!


    Da habe ich die Erweiterung wirklich vergessen! - Man kann ja auch bekloppt sein!


    Ansonsten war wohl immer das Problem, dass ich zu viele Ordner angelegt hatte, und dann eine Datei einfach nicht darin war, weil ich wohl den Überblick verloren habe!


    Als erstes dachte ich, dass du die Erweiterung vom 2. Namen meinst! - Da braucht es keine!

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von Thommy402 ()

  • basti1012 : Danke dir für deine wertvollen Tipps! - Bluefish macht HTML5 mit (ich dachte, dass ich HTML5 schreibe. Nun weiß ich es besser! - DAnke!. - Mein Stand ist ca. 9 Jahre alt, da hast du schon recht - lach!