Links funktionieren nicht

  • Hallo, auf meiner Webseite

    http://reinhold-suessenguth.de/

    die ich mit dreamweaver gebaut habe funktioniert die Verlinkung unter dem Button "Drucke" nicht mehr - ich hatte da etwas ändern wollen --- kann den Fehler jetzt nicht finden.

    Ich füge einen screenshut bei.

    Vielleicht kann mir jemand helfen.


    Danke euch!

  • Welche Verlinkung meinst du genau?

    Ich sehe kein Button Drucke, nur ein Link.

    Unter den LINK Drucke habe ich nur eine Verlinkung "POSTKARTEN" und die funktioniert


    Dein HTML ist aber auch veraltet, was bei Dreamweaver auch kein wunder ist

  • Ich würde eher sagen, der HTML-Code ist eine Katastrophe.

    Nicht nur eine Katastrophe sondern mit dem extrem uralten Macromedia Dreamweaver aus der Steinzeit erstellt, der noch nicht mal was von HTML5 kannte, das war damals noch so und hier wurde noch Tabellen-Design verwendet... 🙈


    Sonst sind noch uralte HTML-Tags wie Font, Color etc. vorhanden, welcher zum Glück per CSS abgelöst wurde :thumbup:


    Wenn es schon ein alter WIYSIWYG-Editor sein soll, dann schau mal bitte nach Microsoft Expression Web 4, der kennt wenigstens noch HTML5 und produziert weniger Müll im Code ;)

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von PadMan ()

  • Hallo und ein gesundes neues Jahr!


    Ich brauche Hilfe bei der Adressierung für mein Android Tablet


    Ich bin Ortschronist und habe meine Homepage auf der Festplatte meines Desktop-Computers.


    Die Adresse:

    C:\Users\Uwe Wartenbach\Pictures\Homepage 31.03. 2021 2\Homepage31.03.2021 1


    Öffnen kann ich sie mit der Adresse:


    file:///C:/Users/Uwe%20Wartenbach/Pictures/Homepage%2031.03.%202021%202/Homepage31.03.2021%201/index.html


    Nun möchte ich sie aber auch auf meinem Android-Tablet öffnen können. Ich habe sie auf der SD Karte unter Homepage31.03.2021 1 und index.html gespeichert.

    Die Tabellen und die Schrift sind zu sehen, aber Keine Bilder und die Verlinkung geht auch nicht.


    Ich nehme an, die Adresse stimmt nicht. Diese zeigt sich als Adresszeile: content://0@media/external/file/29126


    Meine Bitte: Können Sie mir bei der Adressierung der Homepage helfen. Die Homepage soll nicht veröffentlich werden. Sie soll nur auf beiden Festplatten bleiben.

    Ich bin schon 81 Jahre und nicht so bewandert mit HTML.


    Es wäre schön , wenn ich eine Antwort bekommen würde.


    Viele Grüße


    Uwe Wartenbach

  • Hallo Sempervivum!


    Vielen Dank für Deine Zeilen.

    Leider kam ich mit Deiner Hilfe nicht weiter. Mir fehlen einfach einige Kenntnisse

    von HTML. Der Editor bei der Erstellung der HP war der Componsor von Netscape.

    Die Bilder sind alle auf dem Tablet. Die gesamte Homepage wurde 1zu1 kopiert und eingefügt.
    Auch konnte ich sie anfangs wie gewünscht öffnen. Zwischenzeitlich musste ich den Browser auch 'mal wechseln, dann ging es. Unten ist die leider nicht funktionierende Index-Seite auf dem Tablet zu sehen. Rechts die verlinkten html-Dateien und Bilder mit der index.html-Datei.

    Ist es vielleicht sinnvoll die ges. Homepage zu löschen und neu einzufügen?

    Vielleicht kannst Du mir noch einmal einen Rat geben.


    Viele Grüße Uwe Wartenbach


    html-seminar.de/forum/ws/attachment/3268/Screenshot_20220113-182241_My Files3.jpg

  • Composer ist leider sehr stark veraltet.

    Wie ich sehe, liegen die Bilder im selben Verzeichnis wie die HTML-Dateien. Dann müsste ein img-Tag z. B. so aussehen:

    <img src="indust1.jpg">

    Sieh mal in den HTML-Text einer Seite (Rechtsklick und "Seitenquelle" o. ä. je nach Browser) und poste, wie die img-Tags dort aussehen.

  • Hallo Sempervivum!


    Vielen Dank für die vorgeschlagenen Beiträge. Leider komme ich mit der Homepage-Anzeige auf dem Tablet nicht weiter.

    Hier der Quelltext von dem Bild indust1.jpg vom Desktop-Computer. Dieser Quelltext funktioniert.


    Auf meinem Android-Tablet finde ich überhaupt keinen Quelltext. Wahrschein stelle ich mich zu dumm an.


    Ich werde es wohl aufgeben!


    Vielleicht kann ich auf dem Tablet einen HTML-Editor installieren und komme hier weiter.

    Auf meinem Windows 10 Desktop habe ich noch das Programm Microsoft Expression Web 4. Vielleicht gibt es das auch für Android Tablet.


    Vielen Dank noch einmal für die Hilfe.


    Uwe Wartenbach


    Image111.jpg

  • Der Code in deinem Screenshot sieht, sofern es die Verweise und img-Tags betrifft, gut aus.


    Zitat

    Ich werde es wohl aufgeben!

    Bitte nicht so schnell aufgeben, geht nicht gibt's nicht.


    Ich habe das auf meinem Android-Handy (Samsung A50) relativ schnell zum Laufen bekommen, indem ich einen lokalen Webserver installiert habe und zwar den von streamingnology. Wenn man dem Zugriff auf Fotos etc. erlaubt, zeigt er die Bilder im HTML-Dokument an und Links funktionieren. Am besten installierst Du den auf deinem Tablet auch und wenn Du nicht weiter kommst, melde dich wieder.

  • Hallo Sempervivum!

    Vielen Dank für Deine Tipps mit dem lokalen Webserver und die Aufforderung nicht aufzugeben. Ich habe diesen Webserver von streamingnology installiert. Bin aber wohl überfordert damit. Meine Annahme war, dass es eine einfache Lösung gibt.

    Wenn Dir noch etwas einfallen sollte, dann bin ich Dir sehr dankbar. Ich sehe dann regelmäßig in Forum nach.

    Anbei noch einmal die auf dem Tablet geöffnete index-Seite mit der Adressleiste: content://0@media/external/file/29126 deren Bedeutung ich nicht verstehe.


    Danke noch einmal vier Deine Hilfe und herzliche Grüße


    Uwe Wartenbach

  • Keine Sorge, dies:

    content://0@media/external/file/29126

    verstehe ich auch nicht, muss eine interne Adressierung von Android für die Datei sein.


    Ich musste auch ein wenig herum probieren, aber wenn man erst Mal weiß, wie es geht, sind es nur wenige Schritte.


    Beim Start des Webservers siehst Du dieses:

    webserver1.png


    Das unten (roter Pfeil) ist Werbung, musst Du ignorieren.


    Zuerst auf "Start" (blauer Pfeil) tippen, dann wir "Start" ausgegraut, "Stop" wird aktiv und der Status geht auf "running".


    Dann auf die kryptische Zeichenfolge tippen, die mit "http://" beginnt (grüner Pfeil), dann öffnet sich dein Browser und zeigt die Dateien im Wurzelverzeichnis des Dateisystems an:

    webserver2.png


    Ich habe meine Testdateien in das Verzeichnis "Diverses" gelegt (bei dir wäre das "Homepage31.03.2021 1"), tippe ich darauf, zeigt der Browser die Dateien in diesem Verzeichnis an:

    webserver3.png


    Meine Testdatei ist android-local-2.html (bei dir wäre es "index.html". Wenn ich darauf tippe - voila - zeigt der Browser diese Datei mit allen Links und Bildern an.

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Sempervivum ()

  • Hallo Sempervivum!


    Vielen Dank für Deine Angaben. Leider hat es immer noch nicht geklappt. Aber ich bin hoffentlich mit Deiner Hilfe auf dem Weg.

    Die Dateien werden im Wurzelverzeichnis angezeigt. Ich bin dann in den Dateimanager gegangen. Siehe Screenshot unten. Nach der Eingabe von index.html in der oberen Suchleiste in den gewählten /Dateimanager öffnet sich der Google Browser. Welchen Pfad muss ich nun in der Suchleiste von Google eingeben. Ich müsste doch mit der SD-Karte, wo eine Homepage 'drauf ist anfangen und dann weiter über Homepage31.03.2021 1, dann bis index.html fortsetzen. Wenn ich diese Pfad mit den dazugehörigen Zeichen kennen würde, dann müsste es doch klappen?

    Vielleicht kannst Du mir noch einmal einen Rat geben. Vielen Dank.


    Viele Grüße Uwe Wartenbach

  • Das sieht ja schon Mal gut aus, dass Du jetzt in den Browser gelangt bist mit der Anzeige der Dateien. Leider habe ich noch nicht heraus bekommen, wie man dort auf die SD-Karte kommt und ich befürchte fast, dass dieser Server den Zugriff dort nicht unterstützt. Ich habe den Entwickler danach gefragt:

    https://github.com/streamingnology/HTTP-Server/issues

    aber noch keine Antwort und fraglich ob noch eine kommt.

    Durch Eingabe in der Adresszeile (dein pinker Pfeil in dem zweiten Screenshot) funktioniert es leider nicht.

    Das einfachste wäre, wenn Du die Dateien auf den internen Storage kopieren würdest. Ich hoffe, das ist vom Speicherverbrauch her vertretbar.

    Wenn Du nicht weiß, wie das Kopieren geht, erkläre ich es gern.

  • Hallo Sempervivum!


    Es hat geklappt!!!! Durch Deine geduldige Hilfe. Vielen Dank dafür.

    Ich habe die Homepage nun doch auf den internen Speicher kopiert und dann mit dem lokalen Webserver geöffnet. Wie Du es gesagt hast. Alles funktioniert ohne Beanstandungen. Auch über Spiegelung am TV. :):):):)


    Nun kann ich die Homepage ergänzen.


    Nochmals vielen Dank und viele Grüße aus Kirchmöser


    Uwe Wartenbach